Настройка IPTV Билайн через WiFi с использовнием роутеров Mikrotik

Будучи абонентом Домашнего Интернет+ТВ от Билайн волей-неволей читаешь профильные форумы, видишь проблемы абонентов и пр. И вот среди этих «плачей Ярославны» определенно вырисовывается одна задача, которую либо никому не удалось осуществить, либо через костыли с обрезанным функционалом. А именно — передача IPTV на приставку через Wi-Fi. И вот недавно ко мне обратились за помощью именно с таким вопросом. Так как наш человек сначала делает, а потом думает, то ремонт в новой квартирке уже сделан, кабель каналов нет, RJ-45 розеток нет, красоту и эстетику портить никто не будет, а смотреть ТВ от Билайн на кухне хочется. Что же делать? Вырисовываются следующие задачи: 1) Выпустить все клиентские устройства (ноутбуки, компьютеры, планшеты и пр.) в интернет через Wi-Fi 2) На кухонный телевизор поставить арендованную у компании Билайн IPTV приставку и сделать так, чтобы она работала, с сохранением всего функционала. Ну если первый пункт сложностей не вызывает, то второй заставляет задуматься. Поскольку я являюсь приверженцем и давним пользователем продукции компании Mikrotik, то было принято решать возникшую проблему на оборудовании данного вендора. К тому же имеющийся сертификат MTCNA придавал сил и убеждал, что «не так страшен чёрт, как его малюют». Итак, напомню принцип подключения абонентов Билайн к сети интернет. Клиентское оборудование получает от DHCP-сервера «серый» адрес из подсети 10.0.0.0/8, что дает доступ к локальным ресурсам, L2TP-BRAS’ам, ну и собственно тут же бродит multicast нашего IPTV. Чтобы получить доступ непосредственно уже в саму сеть Интернет необходимо авторизоваться по L2TP-соединению по адресу tp.internet.beeline.ru. Данная схема в терминологии некоторых производителей домашних роутеров называется Russian Dual Access. Выбор пал на маршрутизаторы RB/751G-2HnD. aa6bc0ef10ea74714681cd1374e0c88b.jpg Их характеристики: — ОЗУ: 64MB DDR SDRAM — Процессор: Atheros AR7241 400MHz CPU — Жесткий диск: 64MB onboard NAND storage chip — Частота: 2.4 ГГц — Ethernet: 5 независимых портов 10/100/1000 — USB: 1 порт 2.0 — Питание: через ethernet-порт 1 8-30V DC, через джек 8-30V DC (БП в комплекте) — Чувствительность: 802.11g: -96dBm @ 6Mbit/s to -81dBm @ 54Mbit/s, 802.11n: –96 dBm @ MCS0 to –78 dBm @ MCS7 — Усиление мощности: 802.11g: 30dBm @ 6Mbps to 27dBm @ 54 Mbps, 802.11n: 30dBm @ MCS0 to 26dBm @ MCS7 — мощность встроенного радиомодуля: 1W — коэффициент усиления встроенных антенн: 2.5dBi — Энергопотребление: до 7W — ОС: RouterOS, уровень 4 Я не буду подробно описывать где найти winbox, что это и как им пользоваться. Этой информации очень много на просторах сети. Поэтому описывать буду тезисно, но с пояснениями. На момент написания статьи версия ПО 5.24. Качаем ее здесь download2.mikrotik.com/routeros/5.24/routeros-mipsbe-5.24.npk закидываем в Files и перезагружаем роутер. На втором проделываем тоже самое. Итак, определим для себя что R1 это будет роутер, куда приходит кабель от нашего провайдера, а R2 – это этакий Wi-Fi приемник для IPTV-приставки. Дефолтная конфигурация устройств предлагает нам DHCP-клиент на порту eth-1, а порты eth2-eth5 объединены в switch, плюс bridge к eth2 для wi-fi (wlan2) с dhcp-сервером в диапазоне 192.168.88.0/24. Итак, настройка роутера R1 Подключаем к роутеру R1 кабель от билайна в eth1, а компьютер в eth2 и запускаем winbox. Соединяемся с 192.168.88.1 с логином admin и пустым паролем. В окне RouterOS Default Configuration жмем ОК. b4c60ae9c8de055bb3a1d71499f1a778.png Поскольку RouterOS не умеет в полях Connect-to использовать dns-имена, то предварительно, воткнув билайновский кабель в компьютер определяем адрес tp.internet.beeline.ru. В моем случае он оказался 10.255.255.239

/interface l2tp-client add add-default-route=yes allow=pap,chap,mschap1,mschap2 connect-to=     10.255.255.239 dial-on-demand=no disabled=no max-mru=1460 max-mtu=1460      mrru=disabled name=l2tp-out1 password=password profile=     default-encryption user=login

(в сети можно найти скрипты, которые будут сами определять текущий адрес браса tp.internet.beeline.ru и подставлять его в поле Connect-to. т.к. провайдер использует round-robin dns для определения менее загруженного браса) Далее настраиваем два правила NAT. Одно для локальной сети, другое для интернета. Заходим в IP-Firewall-NAT, удаляем правило default configuration, и создаем свои.

/ip firewall nat add action=masquerade chain=srcnat disabled=no dst-address=10.0.0.0/8      out-interface=ether1-gateway add action=masquerade chain=srcnat disabled=no dst-address=!10.0.0.0/8      out-interface=l2tp-out1 

Проверяем оба правила: Следующим шагом убираем членство wlan1 в бридже c ether2 и включаем его в бридж к ether1. Для этого открываем Bridge, создаем новый мост с именем, например, tv-wifi-bridge, а на вкладке Ports добавляем к нему интерфейсы wlan1 и ether1-gateway.

/interface bridge add admin-mac=D4:CA:6D:20:E2:49 ageing-time=5m arp=enabled auto-mac=no      disabled=no forward-delay=15s l2mtu=1598 max-message-age=20s mtu=1500 name=     bridge-local priority=0x8000 protocol-mode=rstp transmit-hold-count=6 add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes      disabled=no forward-delay=15s l2mtu=1598 max-message-age=20s mtu=1500 name=     tv-wifi-bridge priority=0x8000 protocol-mode=none transmit-hold-count=6 /interface bridge port add bridge=bridge-local disabled=no edge=auto external-fdb=auto horizon=none      interface=ether2-master-local path-cost=10 point-to-point=auto priority=     0x80 add bridge=tv-wifi-bridge disabled=no edge=auto external-fdb=auto horizon=none      interface=wlan1 path-cost=10 point-to-point=auto priority=0x80 add bridge=tv-wifi-bridge disabled=no edge=auto external-fdb=auto horizon=none      interface=ether1-gateway path-cost=10 point-to-point=auto priority=0x80 

Т.к. Iptv приставка тоже получает свой адрес от dhcp провайдера, то нам требуется изменить интерфейс dhcp-клиента. Если помните, то он назначен только на ether1. Переназначаем его на Bridge tv-wifi-bridge.

/ip dhcp-client add add-default-route=yes comment="default configuration"      default-route-distance=1 disabled=no interface=tv-wifi-     use-peer-dns=yes use-peer-ntp=yes 

Теперь пришло время настраивать беспроводную часть нашей затеи. В первую очередь подготовим точку доступа именно для iptv приставки. Здесь нет ничего необычного, типовая настройка, за исключением самого важного пункта. Это Multicast Helper. Он должен стоять в положении full.

/interface wireless set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 antenna-mode=     ant-a area="" arp=enabled band=2ghz-b/g/n basic-rates-a/g=6Mbps basic-rates-b=     1Mbps bridge-mode=enabled channel-width=20/40mhz-ht-above compression=no      country=no_country_set default-ap-tx-limit=0 default-authentication=yes      default-client-tx-limit=0 default-forwarding=yes dfs-mode=none      disable-running-check=no disabled=no disconnect-timeout=3s distance=indoors      frame-lifetime=0 frequency=2412 frequency-mode=manual-txpower frequency-offset=0      hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192      ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=     any ht-rxchains=0,1 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,m     cs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,m     cs-19,mcs-20,mcs-21,mcs-22,mcs-23" ht-txchains=0,1 hw-fragmentation-threshold=     disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=     2290 mac-address=D4:CA:6D:20:E2:4D max-station-count=2007 mode=ap-bridge mtu=     1500 multicast-helper=full name=wlan1 noise-floor-threshold=default      nv2-cell-radius=30 nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=     default nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms      periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both      proprietary-extensions=post-2.9.25 radio-name=D4CA6D20E24D rate-selection=     advanced rate-set=default scan-list=default security-profile=default ssid=tv      station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=     6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=     1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 tx-power-mode=default      update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=none      wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=any      wmm-support=disabled 

Шифрование настраиваете по своему вкусу через Security Profiles, останавливаться на этом я не стану. Теперь создаем виртуальную точку доступа, через которую будут попадать в интернет все наши остальные железки (телефоны, планшеты, ноутбуки и пр.). Но сначала добавьте еще один security-profile, чтобы не запутаться.

/interface wireless security-profiles add authentication-types=wpa2-psk eap-methods="" group-ciphers=aes-ccm      group-key-update=5m interim-update=0s management-protection=allowed      management-protection-key="" mode=dynamic-keys name=inet-sec      radius-eap-accounting=no radius-mac-accounting=no      radius-mac-authentication=no radius-mac-caching=disabled      radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username      static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=     none static-key-0="" static-key-1="" static-key-2="" static-key-3=""      static-sta-private-algo=none static-sta-private-key=""      static-transmit-key=key-0 supplicant-identity="" tls-certificate=none      tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key=""      wpa2-pre-shared-key=blablabla 

Ну и сама VirtualAP

/interface wireless add area="" arp=enabled bridge-mode=enabled default-ap-tx-limit=0      default-authentication=yes default-client-tx-limit=0 default-forwarding=yes      disable-running-check=no disabled=no hide-ssid=no l2mtu=2290 mac-address=     D6:CA:6D:20:E2:4D master-interface=wlan1 max-station-count=2007 mtu=1500      multicast-helper=default name=wlan2 proprietary-extensions=post-2.9.25      security-profile=inet-sec ssid=Inet update-stats-interval=disabled      wds-cost-range=0 wds-default-bridge=none wds-default-cost=0 wds-ignore-ssid=no      wds-mode=disabled wmm-support=disabled 

И добавляем полученный wlan2 в бридж к ether2

/interface bridge add bridge=bridge-local disabled=no edge=auto external-fdb=auto horizon=none      interface=wlan2 path-cost=10 point-to-point=auto priority=0x80 

На этом настройки роутера R1 закончены. Проводные девайсы выходит в интернет через порты 2-5, беспроводные через точку доступа wlan2 с SSID “Inet” Настройка роутера R2 Настройка данного роутера вообще банальна. Т.к. Имея дефолтную конфигурацию, нам необходимо всего лишь выполнить сканирование эфира, найти точку с ssid “tv” и нажать кнопку Connect. Если вы используете шифрование, то сделать соответствующие поправки в Security profiles. После этого необходимо ether2 убрать из бриджа, а вместо него добавить ehter1. Осторожно! После этого вы потеряете соединение с роутером и winbox закроется.

Включаем приставку в порт eth1 и всё готово.
Здесь видим записывающийся канал 1HD и одновременную закачку файла. Правда, по такой схеме мне не удалось из VirtualAP выжать больше 7-8 Мегабит. Загрузка процессора роутера, использующегося как точка доступа при такой картине не превышала 34-37% Скорость переключения каналов на глаз не отличается от кабельного подключения. Во время экспериментов пробовал пустить через IGMP – proxy. Вроде и работает, но HD-каналы фризятся, ввод pin-кодов не работает, запись не работает. Также был испробован метод, когда физический AP использовался для интернета, а VirtualAP для телевидения. В данном случае скорость передачи составляла не больше 1Мбит, что естественно недопустимо мало для просмотра ТВ. Вместо видеоряда были стоп-кадры, сменяющие друг друга раз в 30 секунд. На этом эксперимент считаю удачным и оконченным. Имеется широкий простор для дальнейшего тюнинга. Готов ответить на все вопросы. Спасибо за внимание.

Перед настройкой нам нужно обновить прошивку и сбросить все предустановленные настройки.

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Если вы не читали первую часть “Mikrotik: выбор домашнего маршрутизатора“, то вкратце повторю как сбросить настройки, по обновлению прошивки читаем первую часть (ближе к концу).

Подключаемся к маршрутизатору патчкордом в любой порт кроме первого и запускаем WinBox. Через некоторое время наш роутер появляется в списке доступных устройств.

На данном этапе НЕ ПОДКЛЮЧАЕМ КАБЕЛЬ ОТ ПРОВАЙДЕРА В НАШ РОУТЕР!

WinBox – первое подключение

Клацаем мышкой на MAC-адрес что бы он появился в строке Connect To, в поле Login вводим admin, поле пароля оставляем пустым и нажимаем Connect.

Подключившись идём в меню System – Reset Configuration, выставляем галочки No Default Configuration, Do Not Backup и нажимаем Reset Configuration.

MikroTik – сброс конфигурации

Через некоторое время наш маршрутизатор перезагрузится и снова появится в WinBox, на этот раз уже без IP-адреса. Теперь мы готовы приступить к настройкам.

WinBox – подключение на “чистый” роутер

Снова подключаемся к маршрутизатору и заходим в меню System – Users и добавляем нового пользователя с полными правами.

MikroTik – добавление нового пользователя

Выходим из WinBox и подключаемся уже новым пользователем

WinBox – подключение новым пользователем

Снова заходим в System – Users и отключаем старого пользователя. Делается это дабы исключить подбор пароля к вашему роутеру, т.к. практически всем известно имя пользователя по умолчанию. В принципе root для этого тоже не слишком подходит, но для примера пойдёт, вы же придумайте свой логин.

WinBox – отключение старого администратора

На этом в принципе подготовительную часть можно считать завершённой и далее приступим непосредственно к настройкам.

Сразу оговорюсь что в данном примере я подключение от провайдера буду настраивать на физический пятый порт. Сделано это в целях экономии розетки. У меня роутер установлен далеко от розетки и питание на него я подаю по PoE, PoE-in в моём маршрутизаторе (MikroTik hAP ac²) это первый физический порт (который подписан Internet) и если в него воткнуть шнурок от провайдера то придётся подавать питание через PoE-инжектор – раз розетка, плюс розетка на коммутатор (switch), а раз уж все равно кабель от маршрутизатора тянуть к свитчу, то глупо не задействовать PoE от свитча.

Для тех кто не в курсе – у MikroTik’а нет такого понятия как выделенный WAN-порт как на бытовых маршрутизаторах, тут любой порт может выполнять любую роль. Хоть четырёх провайдеров в него заводите, а пятый порт на свитч ))

В принципе все настройки я старался сделать через bridge, так что никому не помешает потом перетусовать все физичесие порты под свои нужды, на работоспособность это уже никак не повлияет.

Но ближе к делу.

В первую очередь идём в меню Interfaces и отключаем порт ether5, для этого выделяем его и нажимаем на красный крестик. После этого можно безбоязненно подключать к нему кабель от интернет-провайдера. Сделано это что бы исключить попытки вторжения на наше устройство пока оно не настроено. На дальнейшие настройки это никак не повлияет.

MikroTik – отключаем порт

Далее идём в меню Bridge и добавляем два моста – bridge1-LAN и bridge2-WAN

  • WinBox – добавляем bridge-LAN
  • WinBox – добавляем bridge-LAN
  • Bridge – что получилось

Далее открываем там же вкладку Ports и добавляем там порты в наши мосты )) Порты ether1-ether4 и wlan1-wlan2 в бридж bridge1-LAN, порт ether5 соответственно в bridge2-WAN

  • Добавляем LAN порты в bridge1-LAN
  • Добавляем WAN порты в bridge1-WAN
  • Bridge – настроеные порты

Затем открываем меню Interfaces и на вкладке Interface List добавляем список ls-LAN-all нажав на кнопку Lists. Затем в данный список добавляем bridge1-LAN

  • Добавляем список интерфейсов
  • Добавляем в список bridge1-LAN

На этом настройка портов и мостов закончена, перейдем к настройке локальной сети ))

Перейдём в меню IP – Addresses и добавим новый адрес (в моём случае это 192.168.253.1, в вашем случае это может быть другой) присвоив его интерфейсу bridge1-LAN. Это и будет адрес нашего маршрутизатора. Адрес нужно добавлять с сетевой маской, так как на скриншоте. В принципе маску можно писать и полной – 192.168.253.1/255.255.255.0

Назначаем IP-адрес маршрутизатору

Далее нам нужно настроить DHCP-сервер, который будет назначать IP-адреса сетевым устройствам в нашей локальной сети. Для этого перейдём в меню IP – DHCP Server и воспользуемся там мастером настроек нажав кнопку DHCP Setup. В принципе для типовой конфигурации можно со всем согласиться как есть привязав сервер к интерфейсу bridge1-LAN, единственно я добавил гугловские адреса DNS-серверов. Здесь может быть несколько вариантов – взять DNS-сервера от провайдера, добавить свои, добавить гугловские, настроить DNS-сервер на нашем маршрутизаторе и раздавать его. Последнему варианту будет посвящена отдельная статья, а пока оставим так – пусть будет гугл.

  • Настройка DHCP-сервера 1
  • Настройка DHCP-сервера 2
  • Настройка DHCP-сервера 3
  • Настройка DHCP-сервера 4
  • Настройка DHCP-сервера 5
  • Настройка DHCP-сервера 6

И напоследок переименуем наш DHCP-сервер в dhcp1-LAN, пригодится в будущем.

Переименовываем DHCP-сервер

Начнём с настройки DHCP-клиента, для этого перейдем в меню IP – DHCP Client. Откроем вкладку DHCP Client Options и добавим там новый параметр со следующими значениями:

Name: parameter_request_list Code: 55 Value: 0x010306212A79F9
Настройка DHCP-клиента – добавляем новый параметр

Затем на вкладке DHCP Client добавляем нового клиента привязав его к интерфейсу bridge2-WAN.

Add Default Route выбираем special_classless, что позволяет получить classless маршрут, так и маршрут по умолчанию в стиле MS.

Привязка DHCP Client к интерфейсу bridge2-WAN

На вкладке Advanced добавляем DHCP Options: clientid, hostnameи наш parameter_request_list. По поводу последнего параметра – не знаю точно передаёт ли билайн до сих пор что нибудь, но на всякий случай пусть будет, отключить никогда не поздно. Default Route Distance ставим 10.

Advanced DHCP Options
/ip dhcp-client add add-default-route=special-classless default-route-distance=10 dhcp-options=     clientid,hostname disabled=no interface=bridge2-WAN

Теперь настроим непосредственно L2TP подключение.

Перейдём в меню PPP и добавим L2TP Client. Назовём его l2tp-out1-beeline, Max MTU установим 1460, Max MRU 1500. Затем на вкладке Dial Out заполним поля Connect To: tp.internet.beeline.ru, User: ваш логин выданный провайдером, Password: соответственно ваш пароль, поставим галочку Add Default Route, Default Route Distance: 5, снимем галочки с mschap1 и pap

  • Настройка L2TP – General
  • Настройка L2TP – Dial Out

Выбираем меню Interfaces и переходим на вкладку Interface List, добавляем новый список ls-WAN-all. Затем в этот список добавляем интерфейсы bridge2-WAN и l2tp-out1-beeline

  • Настройка firewall – добавляем новый список интерфейсов
  • Настройка firewall – добавляем интерфейсы в список
  • Настройка firewall – список интерфейсов

Меню IP – Firewall на вкладке Address Lists добавляем список под названием LocalNet с нашими адресами – 192.168.253.0/24

Настройка firewall – добавляем список локальных адресов

Добавляем привила firewall. Что бы не пихать сюда кучу картинок напишу все правила скриптом, кто не знает, то просто вводите данные команды в окне терминала (меню New Terminal). Данные правила самые базовые, но на первых порах их должно быть достаточно.

/ip firewall filter add action=accept chain=input connection-state=established,related add action=accept chain=forward connection-state=established,related add action=drop chain=input in-interface-list=ls-WAN-all add action=drop chain=forward connection-state=invalid add action=drop chain=forward connection-nat-state=!dstnat connection-state=new in-interface-list=ls-WAN-all

В результате должно выглядеть так как на скрине ниже, за исключением правил для IPTV, их добавим чуть попозже ))

Список правил firewall

На этом этапе можно включить отключенный интерфейс ether5 и попробовать что нибудь попинговать из терминала на MikroTik’е

ping from MikroTik terminal

Как видим интернет на маршрутизаторе уже есть и работает, но если попытаться сделать тоже самое с компьютера из локальной сети то ничего не получится, для этого добавим правила NAT

/ip firewall nat add action=masquerade chain=srcnat out-interface-list=ls-WAN-all src-address=192.168.253.0/24

После этого у нас появился интернет и в нашей локальной сети.

ping from LAN

Если интернет работает, но некоторые сайты почему то не открываются (не по причине блокировки Роскомнадзором) то можно попробовать добавить правило в Mangle

/ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

IPTV от билайна можно настроить двумя способами. Если вам удобнее протянуть кабель от приставки непосредственно к вашему MikroTik’у, то проще всего добавить ещё один порт в bridge2-WAN, предварительно удалив его из brifge1-LAN и подключить приставку в этот порт, например так:

Меняем ether4 с bridge1-LAN на bridge2-WAN

Всё, больше ничего делать не нужно. Именно поэтому я для WAN сделал отдельный мост, а не настраивал как внешний интерфейс непосредственно порт ether5.

Если же вам удобнее IPTV-приставку подключить в коммутатор (switch), то продолжим настройку.

С официального сайта MikroTik из раздела Software нужно будет скачать Extra packages для своей версии прошивки. В моём случае это файл all_packages-arm-6.45.1.zip, т.к. я для написания данного материала пользуюсь MikroTik hAP ac² (RBD52G-5HacD2HnD).

Из полученного архива нам нужен файл multicast-6.45.1-arm.npk (в вашем случае может быть другой, в зависимости от архитектуры процессора и версии прошивки).

Для установки данного пакета в наш MikroTik нужно в WinBox открыть меню Files и в открывшееся окно просто перетащить нужный нам файл. Вместо того что бы перетаскивать, можно воспользоваться кнопкой Upload или просто сделать Copy-Paste. У меня почему то не получилось сделать это из WinBox и я воспользовался доступом через web-интерфейс, который в принципе почти полностью повторяет функционал WinBox, за исключением естественно возможности подключения по MAC-адресам. Так же для загрузки можно воспользоваться доступом по FTP или SFTP.

  • WinBox – logon
  • WinBox – WebFig
  • WinBox – Files

Теперь просто перезагрузим роутер – меню Sytem – Reboot и после перезагрузки данный дополнительный пакет будет установлен в систему, убедиться в этом можно перейдя по меню System – Packages

MikriTik Packages

После установки необходимого нам пакета multicast приступим непосредственно к настройкам.

В меню Bridge открываем bridge1-LAN и включаем там IGMP Snooping

Включаем IGMP Snooping в bridge1-LAN

Тоже из консоли:

/interface bridge set bridge1-LAN igmp-snooping=yes

Routing – IGMP Proxy – нажимаем кнопочку Setup и устанавливаем параметры Query Interval: 30 секунд и Query Response Interval: 20 секунд, Quick Leave оставляем выключенным.

Настройка параметров IGMP Proxy

Из консоли:

/routing igmp-proxy   set query-interval=30s query-response-interval=20s quick-leave=no

Теперь в IGMP Proxy добавляем интерфейс bridge2-WAN с параметрами Alternative Subnets: 0.0.0.0/0, включаем Upstream и интерфейс bridge1-LAN – никаких параметров не меняем.

Из консоли:

/routing igmp-proxy interface add alternative-subnets=0.0.0.0/0 interface=bridge2-WAN upstream=yes add interface=bridge1-LAN

Осталось добавить пару правил в firewall:

/ip firewall filter   add chain=input protocol=igmp action=accept   add chain=forward dst-address=232.0.0.0/5 protocol=udp action=accept

Нужно проследить что бы данные правила были выше первого дропа в цепочке, т.е. правило chain=input protocol=igmp action=accept должно быть выше первого дропа в цепочке input, а правило chain=forward dst-address=232.0.0.0/5 protocol=udp action=accept должно быть выше первого дропа в цепочке forward.

Порядок следования правил в WinBox можно поменять просто перетащив нужное правило на своё место – вверх или вниз. В нашем случае результат будет таким:

Правила firewall для IPTV

Не забывайте к каждому правилу добавлять комментарии, что бы потом не запутаться какое правило за что отвечает.

С настройками IPTV на MikroTik на этом закончим – телевизор показывает ))

В принципе у нас уже всё работает, но необходимо внести ещё парочку мелких изменений в настройки нашего MikroTik.

Отключим все неиспользуемые нами сервисы. Для этого перейдём в меню IP – Services и отключим всё, что мы не используем, а для тех что используем ограничим доступ только из локальной сети:

/ip service set telnet disabled=yes set ftp disabled=yes set www address=192.168.253.0/24 set ssh address=192.168.253.0/24 set api disabled=yes set winbox address=192.168.253.0/24 set api-ssl disabled=yes

И ограничим обнаружение нашего маршрутизатора только в локальной сети:

/ip neighbor discovery-settings set discover-interface-list=ls-LAN-all
Настраиваем Neighbor Discovery

Ну и включим поддержку UPnP для устройств и программ поддерживающих данную технологию, например для торрентов, что бы он смог принимать входящие соединения. Если поддержка UPnP не нужна, то лучше данную опцию не включать, т.к. она может нести в себе определённую угрозу вашей сети.

/ip upnp set allow-disable-external-interface=yes enabled=yes /ip upnp interfaces add interface=bridge1-LAN type=internal add interface=bridge2-WAN type=external

На этом часть про базовые настройки маршрутизатора на основе RouterOS можно считать завершённой.

За бортом остались настройки Wi-Fi, настройки DNS и много чего ещё, но это уже тема последующих статей.

Все приведённые примеры использовались и работают на маршрутизаторе MikroTik hAP ac² (RBD52G-5HacD2HnD-TC) с версией RouterOS 6.45.1.

Отдельно хочу сказать огромное человеческое спасибо своему хорошему другу Владу Глазкову, без его подсказок и советов данной статьи просто не было бы.

С благодарностью приму конструктивную критику и замечания в комментариях.

Обновление от 20.07.2019:В настройках DHCP клиента в parameter_request_list добавил получение Classless Static Route Option, правда в моём регионе (Красноярск) билайн кажется “забил” на это (

Обновление от 17.10.2019: В настройках DHCP клиента удалён параметр parameter_request_list и Add Default Route изменён с yes (по умолчанию) на special-classless, что позволяет получать как classless маршруты так и маршрут по умолчанию в стиле MS.

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Оцените данную запись [Всего голосов: 20 — Общая оценка: 5]

IPTV Билайн – возможность просматривать любимые каналы. Данная услуга появилась у компании довольно давно, она пользуется определенным спросом среди клиентов. В нашей статье расскажем про цифровое телевидение от Beeline, рассмотрим сопутствующие нюансы.

Что такое IPTV от Билайна?

Цифровое ТВ от Beeline появилось в 2009 году. Оно выступает в качестве альтернативы для аналогового телевидения. Давайте перечислим преимущества данной услуги:

  1. Широкий перечень доступных телеканалов, каждый найдет ТВ-программу по душе.
  2. Простота подключения и настройки.
  3. Цифровое ТВ функционирует на различных телевизорах – на обычных моделях, на Андроид, на других операционных системах.
  4. Высокое качество приема сигнала, отсутствие помех.
  5. Отличное изображение на экране.
  6. Оптимальные цены на услуги компании.
  7. Организация занимается развитием цифрового ТВ. Она улучшает качество предоставляемых услуг, добавляет новые опции и телеканалы.
  8. Можно запустить IPTV на компьютере. Но сделать это несколько сложнее, чем на телевизоре.
  9. Компания предоставляет привлекательные цены на оказываемые услуги.

У Beeline представлены выгодные смешанные тарифы. В них оператор включает домашний интернет и цифровое ТВ. Приобретая одновременно две услуги, можно сэкономить средства.

Стоимость зависит от нескольких факторов:

  • списка доступных каналов и скорости интернета;
  • включена ли аренда оборудования;
  • регион, в котором происходит подключение. Цены в различных субъектах РФ сильно отличаются, так как уровень дохода у местного населения разный.

На изображении, расположенном ниже, вы сможете просмотреть предложения для Москвы. Узнать цены в других городах можно на региональной версии официального сайта.

Что входит в комплект оборудования?

Чтобы просматривать IPTV-каналы Билайн, потребуется специальная приставка. Условия ее предоставления можно узнать непосредственно у представителей компании. Клиент может сразу выкупить оборудование, или получить его в аренду за фиксированную плату.

Нередко организация проводит акции. По ним можно получить приставку в аренду за символическую сумму. Но оборудование не становится собственностью клиента, оно остается во владении компании. В случае отключения, абонент обязуется вернуть приставку Beeline.

Некоторые современные телевизоры можно подключить без приставки. Каждый случай нужно рассматривать индивидуально, учитывать технические характеристики конкретного устройства.

В комплект оборудования входит:

  • приставка;
  • кабель HDMI;
  • сопутствующие шнуры для последующего подключения;
  • пульт дистанционного управления.

Настройку IPTV Билайн лучше доверить профессионалам. Обычно специалисты проводят подготовку оборудования при подключении нового абонента. Вам потребуется:

  1. Посетить официальный сайт компании.
  2. Открыть страницу с цифровым ТВ.
  3. Выбрать подходящее предложение.
  4. Нажать на кнопку «Подключить».
  5. Заполнить форму и оставить заявку.
  6. Дождаться звонка менеджера, согласовать время для приема специалиста.
  7. Мастер прибудет с необходимой оснасткой и оборудованием.
  8. Специалист проложит кабели, выполнит подключение оснащения и его настройку.
  9. Вы сможете начать пользоваться цифровым ТВ.

Настройка IPTV Билайн через роутер

Надо понимать, что настройка во многом зависит от конкретного роутера. У техники от разных производителей меню может сильно отличаться. Поэтому рекомендуем предварительно проверить модель вашего роутера, чтобы подобрать настройки именно под нее.

Давайте рассмотрим данную процедуру на примере самых популярных роутеров – TP-Link:

  • первоначально необходимо зайти в Web-интерфейс оборудования;
  • если вверху есть поле для выбора режима, то нужно кликнуть на «Мост»;
  • в отдельных моделях присутствует графа «Порт IPTV STB». Пользователь может выбрать один или два порта. После нужно нажать на кнопку для сохранения.

Плейлист IPTV Билайн

Просматривать IPTV можно не только на телевизоре, но и на компьютере, причем, совершенно легально. Если у вас активирована услуга цифрового ТВ, то необходимо:

  1. Подключить ПК к роутеру.
  2. Установить подходящий плеер на компьютер. Многие пользуются VLC, это одна из самых популярных программ.
  3. Скачать плейлист Билайн ТВ для IPTV m3u.
  4. Закинуть его в плеер и запустить воспроизведение.

Важно! Если у вас не подключен пакет цифрового ТВ, то легальный доступ к телевидению с ПК пользователь не получит.

Можно пользоваться различными обходными путями, но придется столкнуться с рядом проблем:

  • плейлисты со списками каналов не всегда работают корректно;
  • приложение может начать тормозить и вылетать;
  • многие операторы разработали сложные алгоритмы шифрования сигнала, которые проблематично обойти или взломать;
  • нужно регулярно обновлять плейлисты.

Поэтому лучше легально смотреть IPTV Билайн на телевизоре и компьютере. Так вы сможете избежать многочисленных проблем и наслаждаться цифровым телевидением.

IPTV launching Билайн – что делать?

Относительно данной ситуации информация в открытых источниках отсутствует. Поэтому рекомендуем вам связаться со службой технической поддержки при возникновении проблем. Нужно:

  1. Позвонить в поддержку провайдера.
  2. Перевести вызов на оператора и дождаться ответа.
  3. После соединения рассказать о возникшей проблеме.
  4. Если ее нельзя устранить сразу, то оператор составит техническую заявку для квалифицированных специалистов компании. Возможно, придется в дальнейшем принять мастера, чтобы он на месте разобрался с данной ситуацией.

beeline-iptv-join000.jpg

Цифровое телевидение (IPTV) от Beeline появилось в 2009 году. А Саратовскую область интерактивное ТВ пришло в октябре 2010 года. При подключении абонентам предоставляется в аренду STB-приставка и свитч. Модельный ряд IPTV-приставок немаленький: — Без жесткого диска: Cisco CIS 2001, Cisco ISB 2200, Motorola VIP 1200, Motorola VIP 1002E, Tatung STB2530 — C жестким диском: Cisco CIS 430, Cisco ISB 7031, Cisco ISB 2230, Motorola VIP 1216, Motorola VIP 2262E, Tatung STB3210 Так же телевидение от Билайн можно смотреть на игровой консоли XBox 360. Свитчи используются самые простые — D-Link DES-1005D и TRENDnet TE100-S5. Рассмотрим стандартный абонентский комплект. К абоненту оборудование для подключения доставляется в таком вот виде:

beeline-iptv-join003.jpg

Открываем коробку:

beeline-iptv-join004.jpg

Кроме приставки комплект набит кабелями и оборудованием подзавязку — даже HDMI-кабель присутствует.

beeline-iptv-join005.jpg

Компактный свитч от Trendnet тоже уместился в коробку:

beeline-iptv-join007.jpg

В комплекте есть такая приятность, как магнитик — мелочь, а приятно:

beeline-iptv-join006-300x200.jpg

Надо отметить, что фирменная символика Билайн присутствует везде, даже наклейки в комплекте лежат. Схема подключения проста до безобразия — входящий в дом кабель включается с свитч, а от него подключается компьютер и STB-приставка. Если у Вас есть роутер, позволяющий программно выделить 1 порт под STB-приставку, то можно подключить и через него. Если маршрутизатор «не дружит» с IPTV — подключайте его к свитчу:

beeline-iptv-join002.jpg

При первом включении, STB-приставка Билайн сама обновит ПО и подключится к порталу.

Управление телеканалами удобное — можно просто смотреть телепрограмму, просматривая каналы по очереди в списке, можно смотреть каналы,сортированные по тематике, а можно выделить избранные каналы и смотреть только их. По ощущениями — к интерфейсу необходимо сначала немного привыкнуть, но затем ориентироваться будет легко. В список каналов встроена онлайн телепрограмма с функцией «Картинка в картинке«.

DSC_0151.jpg

Отдельно отмечу возможность поставить просматриваемую программу на паузу или отмотать её назад. Так же, интерфейс IPTV от Билайн позволяет  записывать видео на встроенный жесткий диск и просматривать видео по запросу (VoD):

Правда «выковырять» записанное видео из приставки не получится — оно записывается в кодированном виде. Запись телепрограмм можно начать как по нажатию кнопки записи, так и по расписанию. Возможна запись одновременно нескольких программ. Нешифрованными идут всего 9 каналов. Их можно смотреть на компьютере через VLC-плеер. Список каналов для VLC:

Показать скрытое содержимое
#EXTM3U #EXTINF:0,Первый rtp://@233.33.210.86:5050 #EXTINF:0,Россия rtp://@233.33.210.92:5050 #EXTINF:0,Россия 2 rtp://@233.33.210.93:5050 #EXTINF:0,Россия Культура rtp://@233.33.210.60:5050 #EXTINF:0,Вести rtp://@233.33.210.115:5050 #EXTINF:0,НТВ rtp://@233.33.210.82:5050 #EXTINF:0,5СПБ rtp://@233.33.210.6:5050 #EXTINF:0,Карусель rtp://@233.33.210.17:5050 #EXTINF:0,Русская Ночь rtp://@233.33.210.96:5050
Пульт у приставки очень удобный — он программируемый и может управлять 4-мя устройствами:

Причем программировать можно отдельные сочетания клавиш — например управление звуком можно привязать к приставке или к телевизору. Инструкция к пульту идет на английском языке, но на оф.сайте Билайн она есть на русском — ссылка. Кстати, если кому нужно — вот ссылка на мануал по пульту для приставок Motorolla — ссылка К минусам услуги можно отнести то, что к одной приставке подключается только один телевизор. Для другого нужна отдельная приставка. Вторая не очень приятная особенность — относительно долгая загрузка приставки при включении после полного отключения оборудования доступа. В целом, о интерактивном телевидении от Билайн сложилось весьма неплохая картина. Учитывая то, что сейчас комплект оборудования выдается без арендной платы, а пакетные предложения дают возможность экономить до 30% абонентской платы.

Используемые источники:

  • https://habr.com/post/174111/
  • https://grib69.ru/2019/07/16/mikrotik-nastrojka-podkljuchenija-l2tp-ot-bilajn/
  • https://operator-b.com/iptv-bilayn.html
  • https://nastroisam.ru/iptv-ot-beeline/

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
Умное телевидение для дома
Добавить комментарий